Install CozRPG Evolved

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (CozRPG Evolved) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select CozRPG Evolved from the list on the left. The launcher will handle everything else!

CozRPG Evolved Version 1.9

created by Cozmmander on Minecraft Version 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
I would enjoy the modpack even more if you added the Smart Moving Mod, Custom NPCs, and Universal Coins.
TShock_Da_Squid 3 years ago
you need mine fantasy
elliotbarlby 3 years ago
A good mod to add in would be project E and applied energistics, and maybe portal gun those seem like good chooses for a mod pack like this. thnxs for thinking about it
Demon_Ketdeamos 3 years ago
Could you please add Pam's Harvestcraft, Decocraft, Buildcraft, and Biome's O' Plenty.
MNH052303 3 years ago
Modpack runs fine and plays pretty well. Good selection of mods
connor134 3 years ago
I start loading then the moment stage 2 finishes loading the game sends me to a starting game screen, then crashes. I've updated java and I've allocated 6 Gb of RAM.
Drexious 3 years ago
Could you put the crash log on Pastebin and send me it?
Posted by Cozmmander 3 years ago | Modpack Creator
ok put secret rooms, extra utilities, applied energetics for storage
tovir 3 years ago
Why Can't I join the Server -_- ?
kealo 3 years ago
every time I click play it will install the mod stuff then after that it wont do anything...what do I do?
BionicEx0 3 years ago
Make sure you have the latest version of Java 64 bit and uninstall any other previous versions.
Posted by Cozmmander 3 years ago | Modpack Creator
I like this modpack a lot. Very good selection of mods!! This deserves to be #1 trending
mrwormwoman 3 years ago
You Should use Faction's For the server.
Superjm369 3 years ago
Error Downloading a file for the following pack: CozRPG Evolved Failed to download https://libraries.minecraft.net/org/scala-lang/scala-wing_2.11/1.01/scala-swing_2.11-1.0.1.jar Please consult the modpack author. I got that Following Error report upon trying to download the modpack. Hope this helps figure out what went wrong.
AzirNovo 3 years ago
Is there a fix for this?
Posted by AzirNovo 3 years ago
Found the solution to this, My Technic launcher got reset by some Computer settings without my knowledge. In doing so it set my Gb to 1 instead of being higher. If anyone else is having issues downloading this or any pack, Double check this first!
Posted by AzirNovo 3 years ago
If you can it would be great if you upgraded the amount of people available to enter the server.
Demon_Ketdeamos 3 years ago
We are working on upgrading the server so it can handle more than 45 players without any lag. Hopefully you can get in before then!
Posted by Cozmmander 3 years ago | Modpack Creator
When I try to start the Modpack my Minecraft is breaking down
joninyul 3 years ago
Make sure that you have the latest Java 64 bit and no other version installed.
Posted by Cozmmander 3 years ago | Modpack Creator
having trouble installing the mod pack what im getting is Failed to download https://libraries.minecraft.net/org/scala-lang/scala-swing_2.11/1.0.1/scala-swing_2.11-1.0.1.jar any way that you think you can help me would be greatly appreciated
damikeee 3 years ago
Sorry, I was having issues with my web host. It should be working now! :)
Posted by Cozmmander 3 years ago | Modpack Creator
can there be claims? i dont feel safe. golden shovel is the best in my opinion
WoodOfGreen 3 years ago
I think you should add Extra utilities to the pack, it's a very good mod. Please make a mod list.
Reachinq 3 years ago
whats up with your mod packs official server its done :(
willisb006 3 years ago
Sorry, there was an unexpected shutdown. It should be back up and working very soon!
Posted by Cozmmander 3 years ago | Modpack Creator
So I tried playing it, but it said I needed 2 GB of RAM. It also said Java 64 bit was required, which I have, but it will not allow me to allocate over 1 gb to the launcher, any ideas?
Mymomfarted 3 years ago
There must be something conflicting with Java. Check if you have more than one version installed, and make sure it is fully updated.
Posted by Cozmmander 3 years ago | Modpack Creator
Is there a sphax texture pack for this modpack out yet?
thatoneguyyouknow420 3 years ago
There is no official Sphax texture pack for this modpack yet, but you should be able to download all the textures you would need to make one.
Posted by Cozmmander 3 years ago | Modpack Creator