Technic Blog

Technic Launcher Updates

I wanted to take a moment to talk about our recent launch, and where we're going to go from here with Launcher updates.  As some of you are are aware, our new launcher has a much larger file size than the old one.  In fact, the current public build is more than 10 times the size of the old launcher.  Some have suggested that the new interface design is responsible, but the culprit is actually our new multi-lingual support.  18 out of 20 Mb of the current Launcher file size is the three fonts that currently ship with the launcher.  They are 6Mb each because of the universal language support they include.  

Multi-lingual support is really important to us, but the status quo cannot continue: you're tired of the launcher taking so long to update, our network gets saturated on the weekends from people updating the launcher, which makes it harder for you to update your launcher and install our official modpacks.  Nobody appreciates these problems, so let's talk about what we're doing to fix it:

  • First, we've started research and development into a byte-patching API.  When finished, you won't have to redownload the same fonts over and over again, and updates will be even faster than before!
  • Second, we've suspended all promotions to the Stable launcher stream until the byte patching system is in.  This means that you won't see any more updates for a couple weeks.  We will continue doing Beta promotions weekly until then, so if you are suffering from bugs or issues, feel free to see if the Beta stream helps you out.
  • We've removed one of our three fonts, Open Sans Bold, from the launcher for a little while.  It's not used in very many places (although it does look very good where it's used), and it reduced the Launcher installation size by 30% to remove it.  This will hopefully help those who do feel the need to use the Beta promotions update a little bit faster.
  • Lastly, we know that several people have been upset by the update spam we sometimes put out, and so we've implemented a policy that will reduce the number of updates we release.  Every Tuesday, we'll promote a build to Beta, and when the byte-patching system is in, we'll also update the previous week's Beta build to Stable.  Sometimes we'll have to send out some hotfixes in order to fix urgent issues (this is especially possible on the Beta stream), but we'll avoid deviating from this new schedule as much as possible, so that we don't interrupt your play experience.

Last night, I promoted build #216 to Beta.  If you're interested in using the Beta stream, we'd really appreciate it if you joined us in #technic so that we can discuss your thoughts about the current build.  It's also a good place to get help for any other issues you might be encountering.

In addition to the byte-patching update system, over the next weeks and months, we have a lot of great stuff coming to the launcher that we think you'll be pretty excited about.  We can't talk about all of it yet, but here are a few highly-sought-after features that are currently in development:

  • The ability to deactivate the clipboard-sniffer and start the launcher directly into the Modpacks tab.
  • Improved automatic error report generation to help us to diagnose crashes better.
  • Functionality to add packs to your launcher using network sync instead of through the clipboard.
  • The ability to select which java version to use to launch minecraft.
  • Functionality to allow pack authors to declare RAM and java version requirements.
  • And of course, support for even more languages and dialects.

And these only cover new launcher features!  We'll continue to keep you up to date on these developments as they get worked on.  Thanks for playing Technic!

Comments

You must be logged in to comment. Click here to register a new account or log in.
I have a problem my Launcher dont work and when i try to install it theres nothing coming pls help
cescesces 5 years ago
Im on Windows
cescesces 5 years ago
there is a problem when i try to launch a mod pack it wont launch and return to the launcher this problem is for packs that i need to search not the default ones those work fine its packs like crazy craft 2.2 or orespawn
DraggerDragon 5 years ago
same, my sister tried using a modpack I made for her and it wont work anymore
Posted by coltonj96 5 years ago
I think you guys are doing an amazing job! I thank you for this astonishing new launcher, and this beautiful platform. I would also like to thank everyone, definitely including the modpack designers, and creators for making this amazing community. Keep up the awesome work, I look forward to the next step! #Hug&Kiss??
Derpxel 5 years ago
For those of you seeing multiple posts, I apologize for such lag. 'o~o
Posted by Derpxel 5 years ago
how the heck do I make a server now if I don't have the current logisticspipes-mc whatever??
lucap318 5 years ago
hi
jackrain04 5 years ago
hi
jackrain04 5 years ago
hi
jackrain04 5 years ago
same here. for a true exsample i tried to download ftb A.k.A feed the beast, so i download it but it wont show up in my modpacks like it used to
TrUxDeLuX 5 years ago
whops imean when i play it there wont be any mods
TrUxDeLuX 5 years ago
Would it help if you could select the language or languages you want as part of the installation or download process and it then downloads only the languages and their fonts you would actually use? That might save space.
AspieMum 5 years ago
Fix Voltz 3.1.2
Robertusu 5 years ago
Do i have the only macbook what can't use to play Not the defult mod packs?
Makerkidsfree 5 years ago
First thank you to you and the rest of the team for all the hard work. Next any ETA on email validation being fixed for the forums? I saw that GenPage posted elsewhere that it is fixed, but I have currently been unable to use the forums for a number of weeks due to this and continue to try again every day to no avail.
hello
moesla 5 years ago
I could help with a Greek translation.
ramakin 5 years ago
you half to downgrade your windows to 8.0 i had this problem too but i fixed it
Parkeymon 5 years ago
I tried to get Midgar Explorer pack by KillerX20 cause I wanted to download the Final Fantasy 7 Midgar map. I did that on the old launcher and it worked fine. Now it cant even load the pack. It just returns to the launcher and doesnt start the game. What did you do and what are you doing to fix it? / Price
the_price 5 years ago
o meu da erro de invalid ursamed
Igor_RRS123 5 years ago
Você tem minecraft original ou pirata?,pois só funciona no original
Posted by BlazeKicker 5 years ago
theres a problem with the new layout hod do i download new modpacks like user made ones
How do you add packs to the launcher?
CocoJewel20 5 years ago
My launcher just went offline, it opens up and the discover and news pages are blank and i cant install or play mods any more
nicholas789 5 years ago
99% of the modpacks i try to download dont work even ones ive had before and deleted even when there is no update needed its exactly the same sometimes and still does not work and when it does there are no mods it says there is but when i go in a world its vanilla
I want to play his stampy111 ma play minecraft technic pack but not one just for her to make her play technic pack not thank all of you
stampy111 5 years ago
i cant loggin with my mc name skils the password is chanched and i cant chang it back
skils123 5 years ago
TPPI dont work
shunon 5 years ago
TPPI dont work
shunon 5 years ago
I have a problem with the launch! He writes: "Invalid credentials. Invalid username or password" Please help !!!
Mis507 5 years ago
all the mods indicate they are now offline
nicholas789 5 years ago
I have to report a problem, when i enter the name of any modpack, it wont come up it used to work but now it doesn't I hope you guys can fix the problem. :D
LogicalxMC 5 years ago